Upgrading to 7.7.0 and above

The Helpshift SDK v7.7 is a major update and we have made some important changes. If you have questions or feedback, please Contact Us

Support for Swift

With version 7.7.0, Helpshift SDK has added support for Swift. In order to use SDK 7.7.x for your app, Helpshift recommends you to follow the steps, depending on whether your app is made in Swift, ObjectiveC or mix of both. The minimum required XCode version is 10.2. If you have questions or feedback, please Contact Us

  1. Pure Swift App

    No integration impact.

  2. Swift + Objective C app

    No integration impact

  3. Pure Objective C app

    1. Set Always Embed Swift binaries in the build settings to YES
    2. Add /usr/lib/swift to the runpath search paths in the build settings. Make sure it is above the $(inherited) and @executable_path/Frameworks flags
    3. Add $(TOOLCHAIN_DIR)/usr/lib/swift-5.0/$(PLATFORM_NAME) for Xcode 11.x or $(TOOLCHAIN_DIR)/usr/lib/swift/$(PLATFORM_NAME) for Xcode 10.x to the Library Search Paths in the build settings.

Impact on your app

Host app already using Swift iOS Version > 12.2 Impact
Yes Yes No impact.
Yes No No impact.
No Yes Only integration impact. No size impact.
No No 2 MB size addition in final downloaded IPA

Granting iCloud permission for iOS 10 and below

With version 7.7.0, End-users will be able to send files such as pdf, video, etc. where before 7.7.0 end-users could only send images. For iOS 10 and below, to access files in the “Files” app of iOS, developers will need to add iCloud capability with iCloud Documents services enabled. For more info please refer the Prerequisites section here.

Example:

icloud-entitlement.png